Elevated Latency
Resolved·Degraded performance

🎉 The issue has been resolved and we are back to normal.

Thu, Mar 27, 2025, 06:02 PM
(1 week ago)
·
Affected components
Updates

Resolved

🎉 The issue has been resolved and we are back to normal.

Thu, Mar 27, 2025, 06:02 PM

Investigating

🔎 We are currently investigating this live incident.

Thu, Mar 27, 2025, 05:51 PM(11 minutes earlier)