Increased Latency
Resolved·Degraded performance

🎉 The issue has been resolved and we are back to normal.

Fri, Mar 28, 2025, 07:38 PM
(6 days ago)
·
Affected components
Updates

Resolved

🎉 The issue has been resolved and we are back to normal.

Fri, Mar 28, 2025, 07:38 PM

Investigating

🔎 We are currently investigating this live incident.

Fri, Mar 28, 2025, 07:17 PM(20 minutes earlier)