Increased Latency
Resolved·Degraded performance

🎉 The issue has been resolved and we are back to normal.

Fri, Mar 28, 2025, 11:58 PM
(5 days ago)
·
Affected components
Updates

Resolved

🎉 The issue has been resolved and we are back to normal.

Fri, Mar 28, 2025, 11:58 PM

Investigating

🔎 We are currently investigating this live incident.

Fri, Mar 28, 2025, 08:40 PM(3 hours earlier)